NPM下载出错 No compatible version found

http://blog.fens.me/nodejs-npm-no-compatible-version 前言 NPM大家都熟,天天都在用。最近,NPM不断出现的下载出错 “npm ERR! Error: No compatible version found” ,已经影响到正常的开发工作,到了不得不解决的地步了。网上到处都是这个错误的问题 …



CSS3动画的回调处理

我们在做js动画的时候,很多时候都需要做回调处理,如在一个动画完成后触发一个事件、一个动画完成后执行另外一个动画等等,但在使用CSS3动画时能不能捕获到运动的状态做回调处理呢?


不错的Markdown可视化编辑器

分享两款平时常用的Markdown可视化编辑器: Mou: mac下的一款Markdown编辑器,支持编辑字体设置以及主题切换,预览效果也不错,并且可以选择用来显示的css样式。 下载地址:http://25.io/mou/ 下载后解压,然后直接安装即可。 Cmd Markdown:这是一款网页 …


ubuntu下配置node.js环境

今天要在自己的vps上配置node.js环境,安装过程记录如下: ubuntu版本:14.10 nodejs环境:0.10.33 首先,下载nodejs安装包,命令: wget http://nodejs.org/dist/v0.10.33/node-v0.10.33.tar.gz 默认下载到home目录,然后解压文件,命令: tar zxvf …



JavaScript的模块化开发

如今,javascript的使用频率越来越高,代码量也越来越大,从页面上的一些简单的特效到数据的处理,再到复杂的交互,从pc端到移动端,几乎都离不开javascript。如果不对它们进行模块化管理的话,那么开发过程可能会变的越来越困难,页面性能也可能会越来越 …


npm安装报错:WARN package.json, No repository fields

今天在安装npm包时遇到了这个错误,出现如下提示: npm WARN package.json xxx@0.0.0 No repository field. npm WARN package.json xxx@0.0.0 No README data 看字面意思大概是缺少README文件和repository字段,也就是说缺少项目的基本描述文件和仓库 …


页面布局中常用的清除浮动的方法

我们在页面布局时,基本上避免不了使用float,但由此也会引发一些问题,尤其是在容器高度不固定时,此时它的高度完全是由内部的元素撑开的。如果内部元素还是浮动的,那么由于内部的元素脱离了文档流,父容器就不能被撑开了。如果父容器设置的有背景或者 …


phpStorm字体大小无法调整, 怎么办?

最近上手了一款轻量级IDE phpStorm,可是就在调整编辑器字体大小时却遇到问题了, 发现字体大小无法调整,另外还有字体大小往左还有个“√”,始终无法去掉,这个勾限制了字体系列,就可怜巴巴的那几个,就下图那几个: