window下Nodejs的部署


nodejs

 

npm

node cli.js install npm -gf //可以安装最新版的NPM node cli.js install npm@1.0.105 -gf //可以安装指定版本的NPM
npm remove express -g //删除expres

 

supervisor

$ npm install -g supervisor
$ supervisor app.js 

 

Express

express4.X的有一些变化,4.x版本中将命令工具单独分出来了(https://github.com/expressjs/generator),

所有要先按装express-generator,否则创建项目时,会提示express命令没找到

http://expressjs.com/4x/api.html

$ npm install -g express-generator  $ npm install -g express   $ express -V


发表评论

电子邮件地址不会被公开。

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>